North American Network Operators Group

Date Prev | Date Next | Date Index | Thread Index | Author Index | Historical

Re: COnfiguration Suggestion - Etherchannel

  • From: Mike Sawicki
  • Date: Tue Jul 27 22:53:29 2004

On Tue, Jul 27, 2004 at 07:23:29PM -0700, Richard J. Sears wrote:
> 
> Hey Everyone,
> 
> I am building out a  customer that needs more than 1000Mbps of sustained
> bandwidth. Because of the customer equipment, etherchannel was suggested
> as the means to do this (it is compatible with this customers equipment).
> 
> I am running a 6509 with Dual SUP720's in IOS mode only (no cat software).
> 
> It was pointed out that there are really two different ways to configure
> the switch - I guess my question is which is the best (lowest overhead,
> etc)? Hopefully someone out there has been down this road before.
> 
> TIA
> 
> Two methods:
> 
> !
> interface Port-channel2
>  no ip address
>  switchport
>  switchport access vlan 10
>  switchport mode access
> !
> interface GigabitEthernet7/1
>  no ip address
>  switchport
>  switchport access vlan 10
>  switchport mode access
>  channel-group 2 mode on
> !
> interface GigabitEthernet8/1
>  no ip address
>  switchport
>  switchport access vlan 10
>  switchport mode access
>  channel-group 2 mode on
> !
> interface Vlan10
>  description Customer_Name
>  ip address 192.168.0.1 255.255.0.0
>  no ip redirects
>  no ip unreachables
> !
> 
> 
> 
> And then there is this way:
> 
> 
> 
> !
> interface Port-channel2
> description Customer_Name
> ip address 192.168.0.1 255.255.0.0
>  no ip redirects
>  no ip unreachables
> !
> interface GigabitEthernet7/1
>  description Customer_Name EtherChannel Interface #1
>  no ip address
>  channel-group 2 mode on
> !
> interface GigabitEthernet8/1
>  description Customer_Name EtherChannel Interface #2
>  no ip address
>  channel-group 2 mode on
> !
> 

I would use method #2 above.. L3 FEC produces better balancing
results as it is flow based, rather than mac-based.  I'm not 100%
certain that using the SVI interface would not produce a proper
balance, but I doubt it.   Using method one I would expect only one
of the links to be used.

Use method 2 especially if you mean this to be a L3 handoff to the
customer.

Mike Sawicki ([email protected])